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While we are waiting…

• Everyone who wishes to work along with the 
presentation should log onto a machine

• Launch Stata, there should be an icon on the 
desktop

• Do not open anything else yet



Outline
• By the end of this presentation you should be able 

to:

1. Navigate around the Stata interface

2. Import data into Stata

3. Generate, manipulate and obtain descriptive 
statistics for variables

4. Create basic graphs and plots

5. Use and appreciate the wonder of Do files

6. Estimate a basic OLS model and use post-estimation 
commands

7. Keep a log of your work



Stata’s Interface: Windows
Four Main Windows:

1. Review: Lists 
past commands

2. Results: Shows 
recently 
obtained results

3. Variables: 
Names of all 
variables in data 
set

4. Command: 
Where 
commands are 
entered



Stata’s Interface: Menus

• Menus offer a point-and-click alternative to typing commands 
directly into Stata’s command window

File:  Open & 
save data, 
log file 
management.

Data: Data 
manipulation 
functions (e.g. 
sorting, 
merging)

Graphics: 
Multiple 
graphing 
options

Statistics: 
Statistical 
modeling 
functions

Window: 
Organizing 
and 
bringing up 
windows



Stata’s Interface: Toolbar

Begin a new 
log file

Bring up the 
Help Viewer

Bring up the 
Results 
Window

Begin a 
new Do file 
or open an 
existing 
one

Stop 
calculations/
processing

Opens Data 
Viewer for 
Editing

Opens 
Data 
Viewer



Log Files

• Log Files help 
you keep track of 
your work in 
Stata

• After you begin a 
log, every 
command, model 
and all results 
that appear in 
the Results 
window are 
logged.

• Log files can be 
saved and are 
portable.

• Log files can be 
appended, but 
their contents 
cannot be 
modified.



Log Files

To start a log file: 
File > Log > 
Begin

To pause an 
ongoing log: File 
> Log > Suspend

To end an ongoing 
log: File > Log > 
Close

To view a log file: 
File > Log > View



Getting Data into Stata

• Three options:

1. Entering it by hand using Stata’s Data Editor

2. Opening existing data files formated specifically 
for Stata.  These files end in <.dta>.

• File > Open 

3. Import data that is not in Stata format but that 
Stata can understand (e.g. comma-separated 
files <.csv>; tab-delimited data; space delimited 
data).

N.B. If none of the above work  STAT Transfer



Importing Data (non .dta files)
• You must begin with an empty data set before importing data (To do this 
type clear. Note: All unsaved data and changes will be lost.)

Importing data 

created by a 

spreadsheet*

Importing 

formatted 

data

Importing 

formatted 

data

*You cannot import Excel (.xls) files directly.  To get data from Excel to Stata, 

save your Excel spreadsheet as a comma separated file (.csv).  Then import 

it using this option.



Importing a Comma Separated File

1. Browse and 

find the file you 

wish to import.

2. Change file 

type to .csv in the 

“Open File” 

window.

3.Select comma-

delimited data

4. Click Submit

• When you import data into Stata and save, it is saved as a Stata data file.



Memory & Large Data Files
• When importing or opening large data files, 

you may get the following error:

• To get around this, you need to increase the size of memory using the 
set memory command.  For example, to increase the memory available 

to 500 megabytes:

clear

set memory 500m



Data Editor

Preserve: Save 
changes made 
in the data 
editor

Restore: Undo 
all changes 
made in the 
data editor 
since last 
save/preserve

Sort: Sort data 
by selected 
variable

<</ >>: Move 
selected variable to 
the first or last 
column

Hide: Hide 
selected 
variable

Delete: Delete 
selected variable or 
observation -
Choose Wisely or 
else!)

Select cells to 
edit their 
contents 
directly

http://www.youtube.com/watch?v=qOajmNKsb5Q


Describing the Data

• Important Commands:

– sum variables

• Provides summary statistics

– tab variable

• Provides table showing distribution of values

– tab variable1 variable2

• Provides a cross-tab of the two variables

– describe

• Provides a summary of data types in your data



Summary Statistics

To get a 

summary of 

all variables, 

simply type:
sum.

To get a 

summary for 

just one 

variable (e.g. 

FDI), type: 
sum fdi.



Tables and Cross-Tabs

To look at the distribution of a 

variable across its values, simply 

use the tab command e.g.

tab independent_judiciary

For a cross-tab of independent 

judiciary and regime type

tab regime_type 

independent_judiciary



Data Types

• describe

Data Types:

Strings: non-numeric 
variables

Floats: numeric data 
with up to 7 digits 
of accuracy

Byte, int, double and 
long are other 
types of 
numerical data.

Useful commands for changing data types: 
format, destring, encode.



Correlation Matrices

To view the correlation coefficient between one more variables type: 
correlate variable1 variable2 …



Generating New Variables
At times it will be useful for you to generate new variables in your data 

set. Let’s consider regime type, which we measure using Polity data 

(regime_type). This data ranges from -10 to 10, with -10 being full 

autocracies and 10 being full democracies. However, it might be useful 

to simplify this scale, and create a new dummy variable that simply 

reflects whether a state is a democracy or not. 

To do this, let’s begin by generating a new variable called democracy:

democracy = regime_type

This command will generate a new variable called democracy that will 

be identical to the existing polity variable called regime_type.



Recoding Variables
Now, we can work to recode our newly generated democracy variable by determining (arbitrarily) 
that states with a polity score of 6 or higher are democracies, and states with a score of 5 or lower 
are autocracies.

As the results window indicates, we have 
now successfully recoded the democracy 
variable so that it is now dichotomous.

While we could recode each value 
individually, it is much easier to recode the 
entire range at once, which is easily 
accomplished using the /.

democracy -10/5  = 0

democracy 6/10  = 1



“Sort” and “By”
• Sort variable1 

variable2… allows you to 

sort  your data according to 
one or more variables in 
ascending order (place a “-” 
before a variable if you wish 
to sort in descending order).

• Sort and by together 

allow you to sort data 

according to a categorical 

variable, and then run 

various commands for 

each category separately. 

• Using our newly created 

democracy variable, let’s 

investigate the average 

GDP level for democracies 

and non democracies.

democracy

democracy: gpd_pc



Command Structure: The Basics
The command structure in Stata is usually straightforward, although like any 

language there are some exceptions to the basic rules. The vast majority of 

commands follow this basic structure:

The first word 

is usually just 

the name of 

the given 

command you 

want to 

perform, for 

example
regress in 

order to 

estimate a 

regression. 

Following 

the 

command 

name is a list 

of variables. 

When 

estimating 

models, the 

dependent 

variable is 

listed first.

Following the variable list, you may 

enter a comma, which tells Stata that 

you now want to employ one or more 

available options for the given 

command. For example, you may 

want to estimate your regression 

model with robust standard errors. 

This can easily be accomplished by 
typing <, robust> after the last 

variable.



Command Structure: Options

Every command in Stata has 

numerous options that can be 

applied to it to provide very useful 

additional functions. The easiest 

way to determine what these options 

are is through the help menu. To get 

help for a specific command, simply 

type:

help command

The help file provides the basic 

syntax for the given command, as 

well as information on all of the 

possible options that can be added.



Model Estimation: OLS
Let’s say that we want to model GDP per capita using Ordinary Least Squares 

regression, and our theory tells us that GDP varies as a function of regime durability, 

regime type, and several other covariates. We type: 
regress gdp_pc independent variables

By default, Stata 

provides coefficient 

estimates, standard 

errors, and p values in 

the main table.

Above the main results, Stata also provides a 

range of goodness of fit measures including R2.



If

• If statements can be used to limit operations to a subset of the data fulfilling 

the conditions set out by the if statement.  

• For example, we may wish to re-estimate the OLS model using only 

observations that are democracies.  To do this, we put the following statement 
at the end of the command: if democracy == 1.

Note the lower 

number of 

observations



Exporting a Table

• Exporting a table is 

easy. Simply 

highlight the output 

in Stata, right-click 

and select Copy 

Table. From there, 

you can paste your 

results into Word or 

Excel.

CAUTION: This 

output alone is not 

sufficient to turn in 

for your homework, 

let alone a paper. 

This is just an easy 

way to transfer the 

information.  You will 

need to make this 

look more 

professional. 

Useful stata commands that can 
help you do this are estout

and outreg2.



Post-Estimation
Stata offers a range of post-estimation options. After estimating a model, all of these 

commands will apply to the most recently estimated model. Among others, these 
commands include: predict, adjust, level, test, vce and others.

For example, after 

estimating our regression 
model, by typing vce, we 

can obtain the variance 

covariance matrix for the 

model.

Similarly, we could obtain 

the residuals for the model 

using the predict command, 

and the option resid:

newvar, resid



Graphing
Stata is capable of 

producing a range of 

different graphs, and the 

command structure for all 

of these is similar.

To produce a scatter plot 

with GDP per capita along 

the y axis and regime 

durability along the x axis, 

the command is:

gdp_pc

regime_durability



Graphing II
Another useful graph that 

can help you with 

preliminary data analysis 

is a histogram.

In order to produce this 

graph, it is necessary to 

use several options, 

which appear behind the 

comma. In this case, I 

have indicated that the 

variable is discrete, and 

that I want the 

frequencies to be 

displayed, as opposed to 

percentages, etc.

regime_type, discrete frequency



Graphing III
In addition to different sorts 

of graphs, it is also 

possible to produce more 

sophisticated graphs in 

Stata. For example, we 

might want to see if the 

trend we observed in the 

previous scatter plot is 

consistent for both 

democracies and non-

democracies. Using our 

democracy dummy 

variable, and the sort/by 

commands this is possible.

democracy

gdp_pc regime_durability, by(democracy)



Exporting Graphs
• Now that you have produced a graph in Stata, you will ideally want to do 

something with it.

• Graphs in Stata appear in their own window. From there, you can either print 

the graph, or save it elsewhere on your computer. NOTE: producing a new 

graph will overwrite the previous graph, so be sure to save your graph before 

you move onto the next one.  (PNG – Portable Network Graphics is typically a 

very flexible format for saving graphs.)

• As an alternative, you can also copy and paste graphs into documents, but it 

is probably a good idea to keep a saved copy just in case you accidentally crop 

the graph in the document.

• Finally, if you are lucky enough to be working on a mac ;), you can click and 

drag a graph and drop it into a document of your choosing.



The Wonder of Do files

• Do files allow you to store multiple commands 
for future use, manipulation or for batch 
processing

• Click here to 

open a new 

or saved do-

file



Do File Editor
• The Do file editor works just 

like a text editor making it easy 

to write, edit and save your 

commands.  

• To annotate your Do file 

use an * at the beginning of 

each line that you do not

want Stata to attempt to 

run as a command.

• To get Stata to execute 

commands in a Do file 

you can:

1) Run only the portion 

of commands you 

highlight

2) Run all commands in 

the open Do file 



Do Files

• If you forget to work in the do file, you can 
capture all your commands from the review 
window and paste them into a Do file:

1) Right click in the Review editor

2) Select “Copy Review Contents to Clipboard”

3) Open a new or old Do file where you want to 

record the commands

4) Paste into your Do file



Saving Data

• Caution: Data saved in a 
newer version of Stata 
often cannot be opened 
in an older version of 
Stata.

• To save data for use in an 
older version:

File > Save As > 

Select an older version of 
Stata in the “Save As 
Type” drop down menu



Installing packages: Searching
The first step is to do a net search for the package that you are interested 

in. Let’s say for example that you want to install J. Scott Long’s spost 

package.

• To find packages you 

can search using using
the findit command 

by typing:

spost

• You can also find 

packages searching the 

net via the Help menu



Installing Packages: Installing
Once you have 

found the package 

that you want, you 

can select it from the 

list by clicking on the 

highlighted title. 

From there, installing 

the package is as 

easy as clicking the 

install link.



Useful Operators

• There are several important operators and expressions used 

when manipulating variables and constructing if statements.

Operator Function Operator Function

var1 = var2 Makes var1 equal to 
var2

& Boolean operator AND

var1 == var2 Used when comparing 
values (e.g. if var1 
equals var 2)

| (pipe) Boolean operator OR

var1 != var2 As above, but means
does not equal.

<=/>= Greater than or equal to/ 
Less than or equal to

x/y Values in range from x 
to y (also x divide by y 
when manipulating 
variables) 



Upcoming PRISM Events

This upcoming Thursday, January 21st at 11:15 we will be having 

our first Methods Lunch of the new quarter. We will meet in the 

East stairwell and walk to the Wexner Center.

Our next brownbag will be held on Friday, February 26th.  Any 

requests?

• Intro to R? 

• Advanced Data Management in Stata?

• Intro LaTex/BibTex?

• PRISM fashions in the new millennium? 


